New Calendar Event Invites
Incident Report for Meetupcall
Resolved
Everything back to normal.
Posted 3 months ago. Jun 18, 2019 - 19:50 UTC
Monitoring
We are processing event invites that were sent to invite@meetupcall.com during the Google Calendar outage, if you have not received an email confirming the creation of your conference call from us please do get in touch with support@meetupcall.com
Posted 3 months ago. Jun 18, 2019 - 16:27 UTC
Update
We are picking up events created during the outage as Google Calendar slowly comes back to life.
Posted 3 months ago. Jun 18, 2019 - 16:24 UTC
Identified
The issue is related to the world wide outage of Google Calendar. Google have posted "`We're investigating reports of an issue with Google Calendar. We will provide more information shortly. The affected users are unable to access Google Calendar."

If you have an urgent conference call you can still use your Shared ID to join your conference room. This works any time.
Posted 3 months ago. Jun 18, 2019 - 14:36 UTC
Investigating
We are currently unable to process new calendar events sent to invite@meetupcall.com. We are looking into the issue right now. This does not affect any conference call events users have already created nor users' ability to call into Meetupcall.
Posted 3 months ago. Jun 18, 2019 - 14:14 UTC
This incident affected: Meetupcall Invites.