UK Geographic Number
Incident Report for Meetupcall
Resolved
Calls to the number have been completing fine during our monitoring. This issue is resolved.
Posted 8 months ago. Jan 25, 2019 - 17:08 UTC
Monitoring
We have not seen any re-occurrence of this issue since this morning. We will continue to closely monitor the lines and provide updates.
Posted 8 months ago. Jan 25, 2019 - 12:57 UTC
Investigating
We're investigating potential issues with people connecting to our 0330 094 7630 UK number. If you are having trouble connecting to this number please dial our alternate UK number 0203 1372688.
Posted 8 months ago. Jan 25, 2019 - 09:14 UTC
This incident affected: Geographic Dial-in Numbers.