International Numbers
Incident Report for Meetupcall
Resolved
Calls are connecting as normal.
Posted 4 months ago. May 29, 2019 - 10:14 UTC
Monitoring
The issue was short lived and all numbers are back working. If you do have issues connecting to any of our numbers please contact our support team by email: support@meetupcall.com
Posted 4 months ago. May 29, 2019 - 09:51 UTC
Investigating
We are investigating reports that some international numbers are unreachable. We have confirmed that our Worldwide and UK numbers are unaffected are reachable, those are:
+44 203 1372688 (WordWide number) and 03300947630 (UK Number)
Posted 4 months ago. May 29, 2019 - 09:49 UTC
This incident affected: Geographic Dial-in Numbers.