Saudi Arabia, UAE & Kuwait toll free number currently unavailable
Incident Report for Meetupcall
Resolved
We have been advised that the Saudi Arabia & Kuwait toll free number issue has now been resolved.

Apologies for any inconvenience this may have caused.
Posted Mar 17, 2020 - 13:24 UTC
Update
We currently have an alternative toll free number for the UAE 800035770183.

Our line provider is still investigating the current outage for Saudi Arabia & Kuwait and we will advise once we have any further updates.
Posted Mar 17, 2020 - 12:29 UTC
Investigating
We have had reports that people are unable to connect to the Toll Free Number for Saudi Arabia, UAE & Kuwait. We are looking into the problem jointly with our carrier now and will provide updates as they come.

Our Worldwide number is still available to use as an alternative until resolved: +44 203 1372688 to connect to your conference.

For the UAE you can use the following toll free number 800035770183

Apologies for any inconvenience caused.

A full list of all our numbers can be found at http://www.meetupcall.com/numbers
Posted Mar 17, 2020 - 10:44 UTC