Philippines Toll-Free Cease
Incident Report for Meetupcall
Resolved
We have sourced a new Philippines Toll-Free number, this will be going live after some testing. Keep an eye on our numbers page meetupcall.com/numbers as it will be added there when ready.
Posted about 1 month ago. Apr 16, 2018 - 11:27 UTC
Identified
Our carrier for our Philippines Toll-Free number (1800 14420160) has decided to cease all their numbers with immediate affect. This means this number will no longer connect to Meetupcall. This does not affect the Philippine Geographic number nor any of our other numbers. We are working on sourcing a new toll-free number for the Philippines.

If your delegates normally use the Philippines Toll-Free number we recommend you let them know that they should use the Philippines Geographic number (02 555 5220) instead.

Sorry for any inconvenience.
Posted about 1 month ago. Apr 12, 2018 - 16:53 UTC