Reminder Emails not being delivered
Incident Report for Meetupcall
Resolved
This incident has now been resolved, and reminder emails are being sent out as normal, we will continue to monitor.
Posted 6 months ago. Oct 08, 2018 - 10:44 UTC
Investigating
We are currently investigating reports that users are not receiving their 15 minute reminder emails for their calls.

In the meantime, the Dial in details provided in the initial email you received when arranging the call are still valid and can be used.
Posted 6 months ago. Oct 08, 2018 - 09:50 UTC
This incident affected: Meetupcall Emails.