UK Toll-Free 0800
Incident Report for Meetupcall
Resolved
This incident has been resolved.
Posted 11 months ago. Jun 11, 2018 - 13:31 UTC
Update
The issue has been solved and the number is now reachable.
Posted 11 months ago. Jun 11, 2018 - 10:45 UTC
Investigating
We are currently investigating issues dialling our UK Toll-Free number 0800 098 8002. In the meantime you can still dial any of our other numbers, we recommend dialling our geographic number 02030316868.
Posted 11 months ago. Jun 11, 2018 - 10:27 UTC
This incident affected: Toll Free Dial-In Numbers.