Issue with meetings being arranged by calendar (easy invite)
Incident Report for Meetupcall
Resolved
We can confirm the issue was related to a worldwide outage affecting Google's own servers, which we believe has now been resolved.

If you are still experiencing delays with your email invites please do not hesitate to contact support who will be able to assist.

T: +44 (0) 203 137 8933
E: support@metupcall.com
Posted Dec 14, 2020 - 12:57 UTC
Investigating
We are currently investigating an issue with calendar events sent to invite@meetupcall.com.

We believe the issue is related to an outage with all Google applications.

As an alternative you can still use your Shared ID or meeting link to join your meeting.

How to locate your meeting ID & link
https://meetupcall.freshdesk.com/support/solutions/articles/80000051064-where-do-i-find-my-meeting-id-and-leader-pin-

Please contact support if you require assistance locating this on the number below.

TEL: +44 (0)203 137 8933
Posted Dec 14, 2020 - 12:04 UTC
This incident affected: Meetupcall Invites and Meetupcall Emails.