Indonesia Toll-Free
Incident Report for Meetupcall
Resolved
The line and routing have been stable. We are resolving this ticket. If you still have any issues please email support@meetupcall.com
Posted 3 months ago. Nov 16, 2017 - 15:00 UTC
Identified
We are experiencing routing issues with our Indonesia Toll-Free number. As a result calls to this number may not connect. Conference attendees are advised to use an alternative Geographic number, a list is available here: https://www.meetupcall.com/numbers

Or use the world wide access number: +44 203 1372688

Our carrier is working to resolve the routing problem.
Posted 4 months ago. Nov 09, 2017 - 14:09 UTC