Invitations and Reminders Delay
Incident Report for Meetupcall
Resolved
Email delivery times have returned to normal.
Posted 2 months ago. May 04, 2018 - 14:58 UTC
Monitoring
Email delays are now returning to normal. We will continue to monitor delivery times.
Posted 2 months ago. May 04, 2018 - 14:26 UTC
Investigating
Some of our email, such as conference invites and reminders, are experiencing a delay in delivery of up to 10 minutes. We are currently investigating and will update shortly.
Posted 2 months ago. May 04, 2018 - 14:13 UTC
This incident affected: Meetupcall Emails.