Support Phone Lines Unreachable
Incident Report for Meetupcall
Resolved
The problem has been resolved and support phone line is back up and running.
Posted 5 months ago. Aug 03, 2018 - 16:30 UTC
Identified
An issue with our office phone system provider means our support lines are unreachable. If you require support please email support@meetupcall.com.

This does not affect our conference lines.
Posted 5 months ago. Aug 03, 2018 - 16:20 UTC
This incident affected: Support.