Venezuela Toll Free Outage
Incident Report for Meetupcall
Resolved
This number has been withdrawn until further notice.
Posted about 1 year ago. Jul 21, 2017 - 11:33 UTC
Identified
Our provider for the Venezuela Toll-Free number 0800 612 4017. Their support team is actively working on a quick resolution. Users may find that this number does not connect to Meetupcall. We will post updates as we receive them.

Users should try an alternative number if they are having difficulty connecting to the Venezuela number, you can see all our available numbers here: meetupcall.com/numbers

We apologise for the inconvenience this causes.
Posted about 1 year ago. Jun 28, 2017 - 11:20 UTC