0844 Free Plan Numbers
Incident Report for Meetupcall
Resolved
Our 0844 UK Freeplan number is now working.
Posted over 1 year ago. Mar 06, 2017 - 15:40 UTC
Investigating
We're investigating an issue with our UK 0844 Free Plan number. It is currently offline. This does not affect our other geographic and toll-free numbers.
Posted over 1 year ago. Mar 06, 2017 - 14:47 UTC