Bahrain geographic number currently unavailable
Incident Report for Meetupcall
Resolved
Regrettably we have now removed our geographic Bahrain number due to local regulations restricting the use of telephony services by companies outside of the country.

As an alternative the Toll-Free number for Bahrain can still be used (800 19803) as well as our Worldwide number: +44 203 1372688 to connect to your conference.

Apologies for any inconvenience this may cause and rest assured should the situation change we will update you will an alternative number to use.
Posted Dec 02, 2019 - 15:26 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 02, 2019 - 15:14 UTC
Identified
The geographic number for Bahrain is still unavailable and is no longer being advertised while it is reviewed or we source an alternative.

The Local Toll Free number for Bahrain is unaffected 800 19803 or the Worldwide number: +44 203 1372688 can also be used to connect to any conference.

A full list of all our numbers can be found at http://www.meetupcall.com/numbers
Posted Nov 27, 2019 - 14:19 UTC
Investigating
We have been advised by our line provider that the local number for Bahrain is currently being reviewed due to restrictions imposed by the Bahraini regulator and is temporarily unavailable.

As an alternative the Toll Free number for Bahrain can still be used 800 19803 as well as our Worldwide number: +44 203 1372688 to connect to your conference.

A full list of all our numbers can be found at http://www.meetupcall.com/numbers

Apologies for any inconvenience caused during this time.
Posted Nov 26, 2019 - 11:57 UTC
This incident affected: Geographic Dial-in Numbers.