Italy Geographic Line - 0522 184 762
Incident Report for Meetupcall
Resolved
Calls are flowing normally to this number.
Posted about 1 year ago. Jun 15, 2017 - 09:04 UTC
Monitoring
The line has been tested as working. We will continue to monitor inbound traffic.
Posted about 1 year ago. Jun 15, 2017 - 08:48 UTC
Identified
Our supplier in Italy is reporting a partial network outage which may effect joining conferences via the Italian dial-in numbers. We are in close contact with their support team while they’re actively working on a quick resolution, in the meantime, it is recommended attendees joining from Italy use our Worldwide access number: +44 203 137 2688.

We are sorry for any inconvenience this may cause.

Best regards,
Meetupcall Support Team
Posted about 1 year ago. Jun 14, 2017 - 10:18 UTC