Meetupcall Emails to Mimecast Customers
Incident Report for Meetupcall
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 16, 2017 - 12:45 UTC
Monitoring
We have switched email sending service and emails to mimecast customers look to be being delivered as normal. We will continue to monitor the situation.
Posted over 1 year ago. Feb 16, 2017 - 10:45 UTC
Identified
Some customers using the Mimecast platform may experience delayed or undeliverable emails from us. We are investigating. If you are using Mimecast and are not receiving emails from us you should also contact Mimecast to see why they are bouncing emails from our meetupcall.com domain. Adding our domain meetupcall.com to your Mimecast whitelist should also solve the issue.
Posted over 1 year ago. Feb 16, 2017 - 09:21 UTC