Luxembourg Geographical and Toll-Free Outage
Incident Report for Meetupcall
Resolved
Our provider for both the Luxembourg geographic number 27 861 891 and the toll-free number 800 81018 have now advised that the outage has been resolved.

We apologise for the inconvenience this causes.
Posted about 1 year ago. Jul 24, 2017 - 12:20 UTC
Identified
Our provider for both the Luxembourg geographic number 27 861 891 and the toll-free number 800 81018 advice of an outage. Their support team is actively working on a quick resolution. Users may find that this number does not connect to Meetupcall. We will post updates as we receive them.

Users should try an alternative number if they are having difficulty connecting to the number, you can see all our available numbers here: meetupcall.com/numbers

We apologise for the inconvenience this causes.
Posted about 1 year ago. Jul 24, 2017 - 09:43 UTC