Meetupcall - Live Support Chat Issue
Incident Report for Meetupcall
Resolved
Our Support Live Chat is fully operational now. If you have any inquiries please don't hesitate to contact us.
Posted 11 months ago. Mar 09, 2018 - 17:09 UTC
Monitoring
Our Support Live Chat is now operational. We will be monitoring it in the meantime.
Posted 11 months ago. Mar 09, 2018 - 16:25 UTC
Investigating
Our live support chat is currently experiencing issues. Support and business enquiries can still be made by phone (+44 (0)203 137 8933) or by email support@meetupcall.com
Posted 11 months ago. Mar 09, 2018 - 15:16 UTC