Worldwide Number (+44203 137 2688) Issue
Incident Report for Meetupcall
Resolved
We have not seen any more issues with our worldwide number for several hours now. Sorry for the inconvenience, if you have any problems connecting please contact support@meetupcall.com
Posted 7 months ago. Apr 17, 2018 - 14:08 UTC
Monitoring
The issue has now been fixed and we will be monitoring all inbounds calls.
Posted 7 months ago. Apr 17, 2018 - 11:39 UTC
Investigating
Our Worldwide number (+44203 137 2688) is currently experiencing connection problems where users will hear a busy tone. While we investigate this matter, please use the following UK number in replacement of our Worldwide number (+44203 031 6868). We are sorry for the inconvenience.
Posted 7 months ago. Apr 17, 2018 - 09:45 UTC