Telephone Network Congestion
Incident Report for Meetupcall
Resolved
We are able to report there have been no connectivity issues this week joining conference calls via mobile networks.

We would still advise where possible to arrange your conference calls outside of the peak periods of 10am & 2pm to ensure a seamless connection to your call.

We will of course continue to monitor the situation throughout the coming weeks and update where necessary.
Posted Apr 02, 2020 - 17:49 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 25, 2020 - 09:56 UTC
Monitoring
There has been a number of challenges relating to the unprecedented demand for telephone services as globally people are working from home.

This demand is primarily impacting mobile providers and may result in a busy or dead-tone when making calls, including calls to Meetupcall.

Typically retrying the number a few times will result in the call connecting.

Key times when the networks are under high demand are on the hour, especially at:

* 10am
* 1pm
* 2pm

It is our recommendation that you schedule calls outside of these times to ensure a seamless connection to your call.
Posted Mar 25, 2020 - 09:00 UTC