Meetupcall Phone Support Issue
Incident Report for Meetupcall
Resolved
Our Support number is now working. If you have any inquiries please contact us by email at support@meetupcall.com or phone us up from our number (+44203 291 2313).
Posted 3 months ago. Feb 28, 2018 - 10:05 UTC
Monitoring
Our Support phones are now operational and we are able to receive calls from this number (+44203 291 2313). We will be monitoring our lines in the meantime though.
Posted 3 months ago. Feb 28, 2018 - 09:30 UTC
Update
While we are investigating this issue. For emergency only please call +441302244707, this direct line number is one of our support team phones. However, for any other inquiries please email support@meetupcall.com.
Posted 3 months ago. Feb 28, 2018 - 09:10 UTC
Investigating
Our phone services are currently experiencing some issues. We will be investigating this matter immediately. If you have any inquiries of any issues, please contact support@meetupcall.com while we are investigating this issue.
Posted 3 months ago. Feb 28, 2018 - 08:55 UTC