Email invites not being sent out to attendees
Incident Report for Meetupcall
Resolved
This issue has now been resolved.

Please contact support if you are still not receiving email invites when arranging a conference via your calendar and they will be able to assist with your enquiry.

T: +44 (0)203 137 8933
E: support@meetupcall.com
Posted Jun 23, 2020 - 14:52 UTC
Investigating
We are currently investigating an issue where the email invites for new calendar arranged conferences using invite@meetupcall.com are not being sent out to attendees.

If you have an upcoming conference and have not received an email invite, as a work around you can also use your 'shared conference ID' which is located on your conference dashboard under 'Arrange a conference'.

Apologies for the inconvenience, if you have any questions please contact support on +44 (203 137 8933) or email support@meetupcall.com
Posted Jun 23, 2020 - 10:26 UTC
This incident affected: Meetupcall Invites.