Conference Calls Delays
Incident Report for Meetupcall
Resolved
The issue is resolved and services are back to normal. If you have any further inquiries please contact our support team.
Posted 11 months ago. Mar 05, 2018 - 11:24 UTC
Monitoring
We have resolved the delay issue and services are back to normal. However, if you have experienced delays while joining a conference call please notify our support team.
Posted 11 months ago. Mar 05, 2018 - 10:38 UTC
Investigating
We are currently investigating delays with joining conference calls.
Posted 11 months ago. Mar 05, 2018 - 10:29 UTC