Saudi Arabia toll free number currently unavailable
Incident Report for Meetupcall
Resolved
We are satisfied there are no further connection issues and the incident has been resolved.
Posted Mar 12, 2020 - 16:34 UTC
Monitoring
We have been advised by our provider that the line has now been restored and we are currently monitoring the line for continuity of service.

Apologies again for any inconvenience caused.
Posted Mar 11, 2020 - 20:00 UTC
Update
We are still working closely with our line provider to resolve the connection issue.

As a reminder, if you are unable to connect at this time the worldwide number can be used an alternative to join your conference +44 203 1372688
Posted Mar 11, 2020 - 17:49 UTC
Investigating
We have had reports that people are unable to connect to the Toll Free Saudi Arabian number. We are looking into the problem jointly with our carrier now and will provide updates as they come.

Our Worldwide number is still available to use as an alternative until resolved: +44 203 1372688 to connect to your conference.

Apologies for any inconvenience caused.

A full list of all our numbers can be found at http://www.meetupcall.com/numbers
Posted Mar 11, 2020 - 11:28 UTC