Telephone Communication Issue
Incident Report for Meetupcall
Resolved
The support lines are fully operational now.
Posted 10 months ago. Jan 24, 2018 - 10:37 UTC
Monitoring
The support lines are now working. We are currently monitoring the situation.
Posted 10 months ago. Jan 24, 2018 - 09:29 UTC
Investigating
Our Support Lines is currently unavailable. If you have any inquiries please contact us by email to support@meetupcall.com or Live Chat. This issue should not affect any conference calls.
Posted 10 months ago. Jan 24, 2018 - 09:25 UTC