Issue joining conferences over the internet
Incident Report for Meetupcall
Resolved
Please be advised some customer may have experienced some issues joining conferences over the internet from 0950 until 1015.

We are pleased to say this issue has now been resolved and apologise for any inconvenience that may have been caused.

If you do continue to experience any issues please contact support who will be able to investigate this for you straight away.

As an alternative you can still dial into the conference using your local dial-in number and conference ID

A full list of numbers can be found on our website below
https://www.meetupcall.com/numbers/

You can contact support on 0203 137 8933 or email support@meetupcall.com
Posted Aug 21, 2020 - 09:21 UTC
This incident affected: VOIP (Voice over the internet) and Video Meetings.