Italian free plan number.
Incident Report for Meetupcall
Resolved
This issue has been resolved.
Posted about 1 year ago. May 24, 2017 - 10:16 UTC
Monitoring
We have identified issues with people calling our Italy free plan line. We are currently monitoring this with our supplier.
Posted about 1 year ago. May 23, 2017 - 09:56 UTC