Luxembourg geographic & toll-free number currently unavailable
Incident Report for Meetupcall
Resolved
This issue has now been resolved.

Thank you for your patience.
Posted Nov 29, 2019 - 16:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 29, 2019 - 10:41 UTC
Investigating
We have been advised by our line provider that our local and toll-free number for Luxembourg is temporarily unavailable.

As an alternative please use our Worldwide number: +44 203 1372688 to connect to your conference.

A full list of all our numbers can be found at http://www.meetupcall.com/numbers

Apologies for any inconvenience caused during this time.
Posted Nov 29, 2019 - 10:37 UTC
This incident affected: Geographic Dial-in Numbers and Toll Free Dial-In Numbers.