Indonesia Toll Free
Incident Report for Meetupcall
Resolved
This incident has been resolved.
Posted 3 months ago. May 25, 2018 - 08:40 UTC
Monitoring
We have provisioned a new geographical number for Indonesia, 622127899355. A replacement for the Toll-Free number has been ordered but has a long lead time. Please keep an eye out on our www.meetupcall.com/numbers page for updates.
Posted 3 months ago. May 24, 2018 - 16:14 UTC
Identified
Our Indonesia Toll-Free carrier has stopped accepting traffic. We are in the process of finding a new carrier for the service. Please, in the meantime, see our list of numbers for an alternative number that may be close to you geographically or dial our world wide number: +44 203 1372688
Posted 3 months ago. May 24, 2018 - 11:43 UTC
This incident affected: Toll Free Dial-In Numbers.