Geographic Number (UK Worldwide) Outage
Incident Report for Meetupcall
Resolved
Our carrier has resolved their issue. Everything back to normal.
Posted 4 months ago. Jul 13, 2018 - 17:24 UTC
Investigating
We are aware of an issue affecting our UK Worldwide Number (+44 203 1372688). Our carrier notes that a potential router failure in Telehouse London, which is causing an interruption to the service. They are in the process of replacing the equipment which may take up to 1 hour. Please note our alternative UK Worldwide number +44 203 031 6868 is unaffected, please dial this number instead if you are having difficulty connecting to +44 203 1372688. This outage does not affect any other service.
Posted 4 months ago. Jul 13, 2018 - 16:36 UTC
This incident affected: Geographic Dial-in Numbers.