UK Dialin
Incident Report for Meetupcall
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 12:31 UTC
Update
Mobile operators are also experiencing capacity issues, if you are struggling to connect to us please keep trying.
Posted Mar 18, 2020 - 10:42 UTC
Investigating
We are investigating reports of users unable to connect to our main 0330 094 7630 UK number. If you are experiencing problems connecting to that number please redial: 0203 1372688
Posted Mar 18, 2020 - 10:33 UTC
This incident affected: Geographic Dial-in Numbers.