UAE Toll Free - 800035770183
Incident Report for Meetupcall
Resolved
Intermittent issues were caused by local network congestion. Toll-free numbers are all operating correctly.
Posted Mar 25, 2020 - 09:52 UTC
Monitoring
There have been no further reports of connection issues on this line although we will continue to monitor the situation.

The outage that occurred during the busier periods we believe was due to congestion on the line and we will continue to work closely with our carriers to ensure continuity of service.
Posted Mar 25, 2020 - 09:24 UTC
Investigating
We're receiving reports that some customers are having intermittent issues calling UAE toll-free number 800035770183.

If you are experiencing issues you can still dial into your call using our alternative UAE toll-free number which is 8000035703945 or +44 203 1372688.

This could be due to general network congestion due to working from home, but we have raised with out local network operator.
Posted Mar 24, 2020 - 07:48 UTC
This incident affected: Toll Free Dial-In Numbers.