Philippines Geographic Plus Number Issue
Incident Report for Meetupcall
Resolved
The following number (+63 2 555 5220) is now usable. If you have any inquiries or concerns please contact support@meetupcall.com or dial our number (+44 (0)203 137 8933).
Posted 4 months ago. Mar 15, 2018 - 09:25 UTC
Monitoring
Thank you for your patience as we investigated this issue. We will be monitoring the number (+63 2 555 5220) for a one-hour duration for any new occurrence.
Posted 4 months ago. Mar 14, 2018 - 09:21 UTC
Investigating
We have identified that there is an issue with our Philippines Geo Plus number (+63 2 555 5220). If you need to use the Philippines Geo Plus (+63 2 555 5220), please use the following Worldwide number (+44 203 1372688) as an alternative while we investigate this issue.
Posted 4 months ago. Mar 13, 2018 - 10:14 UTC