Issue joining conferences over the internet
Incident Report for Meetupcall
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 16:11 UTC
Investigating
We have been advised that some customers are currently experiencing connection issues joining conferences over the internet. (VOIP)

We are currently investigating the issue and will advise once resolved.

As an alternative you can still dial into the conference using your local dial-in number and conference ID

A full list of numbers can be found on our website below
https://www.meetupcall.com/numbers/

If you have any questions or queries please contact support on 0203 137 8933 or email support@meetupcall.com

Apologies for any inconvenience caused
Posted Jun 01, 2020 - 15:13 UTC
This incident affected: Meetupcall Dashboard.