Issue joining meetings using worldwide number 44 (0) 203 137 2688
Incident Report for Meetupcall
Resolved
We are pleased to advise that all services are again operational.

If you continue to experience any issues please do not hesitate to contact support.

Apologies again for any inconvenience caused during this time.

T: +44 (0) 203 137 8933
E: support@meetupcall.com
Posted Aug 25, 2020 - 11:49 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 25, 2020 - 11:46 UTC
Identified
We have been advised by one of our line providers they are currently experiencing a major outage.

As a result our worldwide number 44 (0) 203 137 2688 & customer support number +44 (0) 203 137 8933 are currently unreachable.

As an alternative for dialing the UK please use our primary number +44 (0) 330 094 7630

To contact support you can email support@meetupcall.com, join online via our live chat or you can reach our team directly on +44 (0) 1302 430856

All other international numbers or dial out options have no reported issues

We apologise for the inconvenience caused and will advise as soon as we have any updates from our line provider.
Posted Aug 25, 2020 - 10:52 UTC
This incident affected: Geographic Dial-in Numbers and Support.