Germany Geographical Outage
Incident Report for Meetupcall
Resolved
Our provider for the Germany Geographic number has advised that the outage has been rectified. Users having difficulty connecting to the number, please contact us via the support@meetupcall.com

We apologise for the inconvenience this had causes.
Posted 10 months ago. Sep 04, 2017 - 16:17 UTC
Identified
Our provider for the Germany geographic number 494079769017 has identified an outage. Their support team is actively working on a quick resolution. Users may find that this number does not connect to Meetupcall. We will post updates as we receive them.

Users should try an alternative number if they are having difficulty connecting to the number, you can see all our available numbers here: meetupcall.com/numbers

We apologise for the inconvenience this causes.
Posted 10 months ago. Sep 04, 2017 - 13:23 UTC