Meetupcall Email Issue
Incident Report for Meetupcall
Resolved
We've been monitoring outbound emails and delivery times have returned to normal.
Posted 7 months ago. Feb 21, 2018 - 16:55 UTC
Monitoring
We are currently monitoring the issue at the moment by observing email delivery times.
Posted 7 months ago. Feb 21, 2018 - 16:02 UTC
Investigating
Meetupcall Emails might be delayed for some users. We are currently investigating this and we will keep you updated.
Posted 7 months ago. Feb 21, 2018 - 15:55 UTC