Partial outage impacting UK toll free number 0800 098 8002
Incident Report for Meetupcall
Resolved
We have been advised by our line provider that the partial outage has now been resolved.

We apologise for any inconvenience that may have been caused, if you are still experiencing any issues joining meetings please do not hesitate to contact support.

Email: support@meetupcall.com
Tel: +44 (0) 203 137 8933
Posted Sep 18, 2020 - 07:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2020 - 16:17 UTC
Identified
The issue has been identified and maintenance is currently taking place by the provider to have it quickly resolved.
Posted Sep 17, 2020 - 13:25 UTC
Investigating
We have been advised by one of our line providers they are currently experiencing a partial outage, that may be impacting our Toll free number in the UK.

As a result our toll free number 0800 098 8002 may be unreachable.

As an alternative for dialing the UK please use our primary number +44 (0) 330 094 7630

To contact support you can email support@meetupcall.com, join online via our live chat or you can reach our team directly on +44 (0) 203 137 8933

All other numbers or dial out options have no reported issues

We apologise for the inconvenience caused and will advise as soon as we have any updates from our line provider.
Posted Sep 17, 2020 - 10:12 UTC
This incident affected: Toll Free Dial-In Numbers.