Dial Out
Incident Report for Meetupcall
Resolved
After monitoring for the day dialouts are operating as normal.
Posted 4 months ago. Nov 06, 2017 - 16:47 UTC
Monitoring
Dial outs this morning and for a portion of Sunday evening were not working for some customers. This has now been rectified.
Posted 4 months ago. Nov 06, 2017 - 09:15 UTC