Partial outage impacting UK toll free number 0800 098 8002
Incident Report for Meetupcall
Resolved
The UK toll free number is now fully operational.

Apologies for any inconvenience caused during this time.
Posted Oct 20, 2020 - 07:42 UTC
Investigating
We have been advised by one of our line providers they are currently experiencing a partial outage, that may be impacting our Toll free number in the UK.

As a result our toll free number 0800 098 8002 may be unreachable.

As an alternative for dialing the UK please use our primary number +44 (0) 330 094 7630 or worldwide number +44 203 1372688

To contact support you can email support@meetupcall.com, join online via our live chat or you can reach our team directly on +44 (0) 203 137 8933

All other numbers or dial out options have no reported issues

We apologise for the inconvenience caused and will advise as soon as we have any updates from our line provider.
Posted Oct 19, 2020 - 12:59 UTC
This incident affected: Toll Free Dial-In Numbers.