Germany Number Issue
Incident Report for Meetupcall
Resolved
The German geographic number and the toll-free number is currently operational. If you have any issues, please contact support@meetupcall.com.
Posted 5 months ago. Feb 22, 2018 - 09:00 UTC
Monitoring
Our German geographic number and the toll-free number is now available to dial. Our carrier resolved the issue but we will be monitoring the geographic number and the toll-free number in the meantime.
Posted 5 months ago. Feb 21, 2018 - 16:13 UTC
Investigating
Our German Geographic number (040 797 69017) and toll-free number (0800 723 6195) is currently unavailable. Our carrier is currently working on this issue. In the meantime, please use the worldwide number (+44 203 1372688) while we investigate this matter.
Posted 5 months ago. Feb 21, 2018 - 10:08 UTC