Processing Invites
Incident Report for Meetupcall
Resolved
Processing times have returned to normal.
Posted 5 months ago. Jun 07, 2018 - 21:38 UTC
Update
Processing times have reduced. We are continuing to monitor.
Posted 5 months ago. Jun 07, 2018 - 20:09 UTC
Investigating
We are experiencing a delay in processing some conference event invites.
Posted 5 months ago. Jun 07, 2018 - 17:02 UTC
This incident affected: Meetupcall Invites.