Germany Geographic Number Issue
Incident Report for Meetupcall
Resolved
The German geographic number and the toll-free number is currently opertional. If you have any issues, please contact support@meetupcall.com.
Posted 3 months ago. Feb 20, 2018 - 16:25 UTC
Monitoring
Our German geographic number and the toll-free number is now available to dial. Our carrier resolved the issue but we will be monitoring the geographic number and the toll-free number in the meantime.
Posted 3 months ago. Feb 20, 2018 - 14:26 UTC
Update
Our German Toll-Free number (0800 723 6195) could be also affected by this issue. We recommend using the worldwide number (+44 203 1372688).
Posted 3 months ago. Feb 20, 2018 - 10:20 UTC
Investigating
Our German Geographic number (040 797 69017) is currently unavailable. Our carrier is currently working on this issue. In the meantime, please use the worldwide number (+44 203 1372688) while we investigate this matter.
Posted 3 months ago. Feb 20, 2018 - 09:49 UTC