Partial outage impacting International dialing numbers
Incident Report for Meetupcall
Resolved
This incident has been resolved.
Posted May 04, 2021 - 11:41 UTC
Update
We have been advised that service has now been restored.

We are currently monitoring the situation and will be testing each line to make sure there are no further issues.

If you are still experiencing problems joining a meeting please contact support.

Email: support@meetupcall.com
Telephone: +44 (0) 203 137 8933
Posted May 04, 2021 - 09:36 UTC
Identified
We have been advised by one of our line providers they are currently experiencing a partial outage, that may be impacting some of our international dialing numbers.

As an alternative the worldwide number +44 203 1372688 is available to join any meeting.

Dial out and joining over the internet is unaffected and can also be used as an alternative method.

Apologies for the inconvenience.

If you have any questions or queries you can contact support by email support@meetupcall.com join online via our live chat or you can reach our team directly on +44 (0) 203 137 8933.
Posted May 04, 2021 - 09:30 UTC
This incident affected: Geographic Dial-in Numbers.