Israel Geographic and Toll Free Number
Incident Report for Meetupcall
Resolved
We have run testing against these lines both locally and internationally and they are both now performing normally.
Posted 11 months ago. Jul 06, 2017 - 14:23 UTC
Identified
We're seeing intermittent problems with people connecting to our Israeli geographical and Toll Free lines. If you are experiencing issues please call our alternative number + 972 (3) 3760893 for Geographic and + 972 (1809) 494509 for Toll Free.
Posted 11 months ago. Jul 06, 2017 - 12:42 UTC