International Numbers
Incident Report for Meetupcall
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 18, 2019 - 22:30 UTC
Update
Systems have been stable over the past few hours. We are resolving this status.
Posted 6 months ago. Mar 18, 2019 - 22:30 UTC
Update
Normal service has been restored. Sorry for any inconvenience. If you are still having issues connecting please do let us know by emailing us at support@meetupcall.com

We will continue to monitor services for the remainder of the evening before declaring this all resolved.
Posted 6 months ago. Mar 18, 2019 - 19:28 UTC
Update
We are aware of issues with people being unable to connect to the UK Toll-Free number, we are working on a solution with our carrier. We recommend you instead dial the UK number 0330 094 7630, this number is included within many mobile plans and land-line minutes bundles.
Posted 6 months ago. Mar 18, 2019 - 17:25 UTC
Update
Whilst service for most international numbers has been restored we are still seeing problems with the Belgium Geographic and UK Toll-Free numbers. We are investigating further.
Posted 6 months ago. Mar 18, 2019 - 17:01 UTC
Monitoring
We have identified the issue at our carrier and have re-routed calls to avoid the connection issues. All international numbers are back working. If you do still have any issues please contact us on support@meetupcall.com
Posted 6 months ago. Mar 18, 2019 - 16:35 UTC
Investigating
We are investigating reports some international numbers are not reachable. If you are having trouble dialling in via an international number please dial our world wide number: +44 203 1372688
Posted 6 months ago. Mar 18, 2019 - 16:15 UTC
This incident affected: Geographic Dial-in Numbers and Toll Free Dial-In Numbers.